Skip to main content
VulnerabilityPublished Updated

CVE-2026-99050: Linux kernel · gpio: mpsse: fix race when arming the IRQ poll worker

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in c0071ee496e1228976c72b096f529503222708a0 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in c0071ee496e1228976c72b096f529503222708a0, 76390ac0bca7e5058b7482eb4d951c3bda5df812, 7efa1a1953cd6b20b23a3524d5b4b81789c6ef25 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to c0071ee496e1228976c72b096f529503222708a0, 76390ac0bca7e5058b7482eb4d951c3bda5df812, 7efa1a1953cd6b20b23a3524d5b4b81789c6ef25 or 6.18.57.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=6.18.6 <6.18.57
Fixed in
  • c0071ee496e1228976c72b096f529503222708a0
  • 76390ac0bca7e5058b7482eb4d951c3bda5df812
  • 7efa1a1953cd6b20b23a3524d5b4b81789c6ef25
  • 6.18.57
LinuxLinuxAffected
  • =6.19
Fixed in–

AI-suggested

A fix for this vulnerability is available in Linux kernel version 6.18.57. Users and administrators should upgrade affected Linux kernel versions (>=6.18.6 <6.18.57 and =6.19) to 6.18.57 or later to remediate this issue. No additional mitigations are specified by the vendor advisory.

Description

CVE-2026-99050 is a high-severity use-after-free vulnerability in the Linux kernel's gpio mpsse driver. It occurs due to a race condition when arming the IRQ poll worker, allowing the USB core to free memory while the worker still accesses it. The flaw is fixed by synchronizing worker publication and arming within a critical section and introducing a dying flag to safely manage teardown. The vulnerability affects Linux kernel versions from 6.18.6 up to but not including 6.18.57, and version 6.19. A fix is available in version 6.18.57.

References

Community reviews

Loading reviews…