Skip to main content
VulnerabilityPublished Updated

CVE-2026-99083: Linux kernel · ksmbd: fix heap out-of-bounds write in krb5_authenticate()

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 517404e157395d0f8da125ca956c566895dfcd06 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 517404e157395d0f8da125ca956c566895dfcd06, 4722d06b2907585074252061b1024a696c1cfc23, 80af1bde97d5a85ad6f2c40ca894ccc8fa75a27a +5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=5.15.145 <5.16
  • >=6.1.40 <6.2
  • >=6.4.5 <6.5
Fixed in
  • 517404e157395d0f8da125ca956c566895dfcd06
  • 4722d06b2907585074252061b1024a696c1cfc23
  • 80af1bde97d5a85ad6f2c40ca894ccc8fa75a27a
  • 59c6dcc5dd9dafe764ca0d40525933b2be69b059
  • 23a0be6a84a38ac169eeab49017934e8e27c65f0
  • 6.5
  • 6.2
  • 5.16
LinuxLinuxAffected
  • =6.5
Fixed in–

AI-suggested

This vulnerability has been fixed in Linux kernel versions 5.16, 6.2, and 6.5. Users and administrators should upgrade affected Linux kernel versions to these or later releases to remediate the issue. No additional mitigation steps are indicated beyond applying the official patches.

Description

CVE-2026-99083 is a high-severity vulnerability in the Linux kernel's ksmbd component affecting versions from 5.15.145 up to but not including 5.16, 6.1.40 up to but not including 6.2, 6.4.5 up to but not including 6.5, and version 6.5. The flaw is a heap out-of-bounds write in the krb5_authenticate() function caused by an incorrect calculation of buffer headroom when processing compounded SMB2_SESSION_SETUP requests. This miscalculation allows memcpy() to overwrite adjacent kernel heap memory. The issue has been fixed in Linux kernel versions 5.16, 6.2, and 6.5.

References

Community reviews

Loading reviews…