Skip to main content
CVE-2026-40553VulnerabilityPublished Updated

gawk · Stack-based Buffer Overflow

Affects MicrosoftSource GCVE Database

0
Compare
Authoritative record:CVE-2026-40553· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 5.4.1 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Debian debian/gawk package to 5.4.1.

Affected software

ProductAffectedFixed in
GNUgawkAffected
  • <=5.4.0
Fixed in–
Debiandebian/gawkpkg:deb/debian/gawkOther threatsAffected
  • <5.4.1
Fixed in
  • 5.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2026-40553 is a stack-based buffer overflow vulnerability affecting version 3.0 of gawk. The vulnerability is categorized under CWE-121. There is no CVSS score available, and no known exploits in the wild have been reported.

References

Community reviews

Loading reviews…