CVE-2026-45149: Node brace expansion · The brace-expansion library generates arbitrary strings containing a common prefix and suffix
Affects node-brace-expansionSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 5.0.6 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade brace-expansion to 5.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmbrace-expansionpkg:npm/brace-expansionOther threats | Affected
| Fixed in
|
Ubuntu 18.04 LTSnode-brace-expansionpkg:deb/ubuntu/node-brace-expansion?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSnode-brace-expansionpkg:deb/ubuntu/node-brace-expansion?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnode-brace-expansionpkg:deb/ubuntu/node-brace-expansion?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnode-brace-expansionpkg:deb/ubuntu/node-brace-expansion?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 25.10node-brace-expansionpkg:deb/ubuntu/node-brace-expansion?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available from Red Hat to fix this vulnerability in affected versions 5.0.0 through 5.0.5 of the brace-expansion library included in Red Hat Hardened Images RPMs. Users should apply the update as provided by Red Hat. No effective mitigations meeting Red Hat's criteria are currently available other than applying the official fix.
Description
This update includes the following RPMs: nodejs24: * nodejs24-24.15.0-1.hum1 (aarch64, x86_64) * nodejs24-bin-24.15.0-1.hum1 (noarch) * nodejs24-devel-24.15.0-1.hum1 (aarch64, x86_64) * nodejs24-docs-24.15.0-1.hum1 (noarch) * nodejs24-full-i18n-24.15.0-1.hum1 (aarch64, x86_64) * nodejs24-libs-24.15.0-1.hum1 (aarch64, x86_64) * nodejs24-npm-11.12.1-1.24.15.0.1.hum1 (noarch) * nodejs24-npm-bin-24.15.0-1.hum1 (noarch) * v8-13.6-devel-13.6.233.17-1.24.15.0.1.hum1 (aarch64, x86_64) * nodejs24-24.15.0-1.hum1.src (src)
References
- access.redhat.com/errata/RHSA-2026:13874 (opens in a new tab)
- images.redhat.com (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-45149 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_13874.json (opens in a new tab)
- ubuntu.com/security/CVE-2026-45149 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-45149 (opens in a new tab)
- github.com/juliangruber/brace-expansion/security/advisories/GHSA-jxxr-4gwj-5jf2 (opens in a new tab)