Skip to main content
VulnerabilityPublished Updated

CVE-2026-46527: Cpp httplib · Prior to 0.44.0, When the server has called Server::set_trusted_proxies() with a non-empty trusted-proxy list, an attacker can send an HTTP request

Affects cpp-httplibSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.44.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.44.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade yhirose/cpp-httplib to 0.44.0.

Affected software

ProductAffectedFixed in
GitHubyhirose/cpp-httplibpkg:github/yhirose/cpp-httplibOther threatsAffected
  • <0.44.0
Fixed in
  • 0.44.0
Ubuntu Pro 22.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 0.9.9+ds-1 – 0.10.3+ds-1ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu Pro 24.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 0.13.1+ds-1ubuntu1 – 0.14.3+ds-1.1ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu 25.10cpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=questingOther threatsAffected
  • =0.18.7-1
  • =0.18.7-1ubuntu0.25.10.1
  • =0.18.7-1ubuntu0.25.10.2
Fixed in–
Ubuntu 26.10cpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=stonkingOther threatsAffected
  • =0.26.0+ds-2ubuntu3
  • =0.26.0+ds-2ubuntu4
Fixed in–
Ubuntu Pro 26.04 LTScpp-httplibpkg:deb/ubuntu/cpp-httplib?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 0.18.7-1 – 0.26.0+ds-2ubuntu3+esm1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade cpp-httplib to version 0.44.0 or later, where this vulnerability is fixed. No other mitigations are indicated or required.

Description

cpp-httplib versions prior to 0.44.0 contain a vulnerability when the server uses a non-empty trusted proxy list via Server::set_trusted_proxies(). An attacker can send an HTTP request with a malformed X-Forwarded-For header that leads to undefined behavior by causing the server to access an empty vector, resulting in abnormal process termination (denial of service). This issue is fixed in version 0.44.0.

References

Community reviews

Loading reviews…