Skip to main content
VulnerabilityPublished

CVE-2026-29810: CyberPanel before 2.4.4 omits a "return 0" that is required by the business logic

Affects cyberpanelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.4.4 when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade usmannasir/cyberpanel to 2.4.4.

Affected software

ProductAffectedFixed in
GitHubusmannasir/cyberpanelpkg:github/usmannasir/cyberpanelOther threatsAffected
  • <2.4.4
Fixed in
  • 2.4.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CyberPanel to version 2.4.4 or later where the missing "return 0" statement has been corrected. No other mitigation guidance is provided. Patch status is not explicitly confirmed in the input data, but the version 2.4.4 is indicated as the fixed version.

Description

CyberPanel before 2.4.4 omits a "return 0" that is required by the business logic.

References

Community reviews

Loading reviews…