Skip to main content
VulnerabilityPublished Updated

CVE-2026-79752: CakePHP · Multiple methods in FunctionsBuilder vulnerable to SQL injection

Affects cakephp/databaseSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 5.3.7 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.3.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade cakephp/database and cakephp/cakephp to 5.3.7.

Affected software

ProductAffectedFixed in
Packagistcakephp/databaseAffected
  • >=5.3.0 <5.3.7
Fixed in
  • 5.3.7
Packagistcakephp/cakephpAffected
  • >=5.3.0 <5.3.7
Fixed in
  • 5.3.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available in CakePHP versions 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7. Users should upgrade to these versions to remediate the vulnerability. As a temporary workaround, do not pass user-controlled data to the $dataType, $part, or $unit parameters of the affected FunctionsBuilder methods.

Description

Multiple methods in CakePHP's FunctionsBuilder component are vulnerable to SQL injection when user-controlled data is passed to specific parameters. The affected methods are cast(), extract(), datePart(), and dateAdd(). This vulnerability allows attackers to inject malicious SQL code via the $dataType, $part, or $unit parameters. Fixed versions have been released across multiple CakePHP versions. Users are advised not to supply user-controlled data to these parameters as a workaround.

References

Community reviews

Loading reviews…