Skip to main content
VulnerabilityPublished

CVE-2026-50274: dd-trace-go · Improper parsing of W3C baggage headers may lead to DoS

Affects github.com/DataDog/dd-trace-goSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High : upgrade to 2.8.1 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/DataDog/dd-trace-go/v2 to 2.8.1.

Affected software

ProductAffectedFixed in
Gogithub.com/DataDog/dd-trace-goAffected
  • <=1.24.1
Fixed in–
Gogithub.com/DataDog/dd-trace-go/v2Affected
  • <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade kubernetes-dns-node-cache to version 1.26.8-r6 or later to apply the official fix for CVE-2026-50274 and the related vulnerability GHSA-74j5-xf3v-crq8. No additional mitigations are specified beyond applying the patch.

Description

The kubernetes-dns-node-cache package version 1.26.8-r6 addresses two vulnerabilities including CVE-2026-50274. This vulnerability is classified under CWE-770 and affects versions prior to 1.26.8-r6, including versions less than or equal to 1.24.1 and less than 2.8.1. The issue has been assigned a high severity rating. A patch is available to remediate the vulnerability.

References

Community reviews

Loading reviews…