CVE-2026-45086: Decidim · Forms admin question editor lacks authorization
Affects decidim-demographicsSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.31.5 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade decidim-demographics to 0.31.5; decidim-demographics to 0.32.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsdecidim-demographics | Affected
| Fixed in
|
| RubyGemsdecidim-demographics | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this broken access control vulnerability is available in Decidim's GitHub repository (pull request 16665). Users should apply this official fix to restrict access to the demographics questionnaire admin editor to administrators only. As a temporary workaround, disabling the decidim-demographics module will prevent unauthorized access to the admin editor interface.
Description
Decidim's demographics questionnaire admin editor lacks proper authorization checks, allowing normal participants to access and modify the admin question editor interface. This vulnerability permits low-privilege users to reach and interact with question-management features that should be restricted to administrators. The issue affects versions 0.31.0 up to but not including 0.31.5 of the decidim-demographics module. A patch is available as referenced in the Decidim GitHub repository. As a workaround, disabling the decidim-demographics module can prevent exploitation.