CVE-2024-45594: Decidim-meetings Cross-site Scripting Vulnerability
Affects decidim-meetingsSource GCVE Database
Not known to be exploited : upgrade to 0.28.3 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.28.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade decidim-meetings to 0.28.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsdecidim-meetings | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The recommended mitigation is to disable the creation of meetings by participants in the meeting component to reduce the attack surface.
Description
decidim-meetings versions 0.28.0 up to but not including 0.28.3 contain a cross-site scripting (XSS) vulnerability in the meeting embeds feature used for online or hybrid meetings. This vulnerability can be triggered through a malformed URL, potentially allowing an attacker to execute malicious scripts in the context of the affected application. A recommended workaround is to disable the creation of meetings by participants in the meeting component to mitigate the risk.
References
- github.com/decidim/decidim/security/advisories/GHSA-j4h6-gcj7-7v9v (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-45594 (opens in a new tab)
- github.com/decidim/decidim (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-meetings/CVE-2024-45594.yml (opens in a new tab)