Skip to main content
VulnerabilityPublished

CVE-2026-45330: Decidim · Verification admins can access supplied IDs from other organizations

Affects decidim-verificationsSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.9 Medium : upgrade to 0.30.9 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.30.9, 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade decidim-verifications to 0.30.9; decidim-verifications to 0.31.5; decidim-verifications to 0.32.0.

Affected software

ProductAffectedFixed in
RubyGemsdecidim-verificationsAffected
  • <0.30.9
Fixed in
  • 0.30.9
RubyGemsdecidim-verificationsAffected
  • >=0.31.0.rc1 <0.31.5
Fixed in
  • 0.31.5
RubyGemsdecidim-verificationsAffected
  • >=0.32.0.rc1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available as referenced in the Decidim GitHub pull request https://github.com/decidim/decidim/pull/16666. Users should upgrade to version 0.30.9 or later where this issue is fixed. As a temporary workaround, disabling the "Identity documents" verification feature prevents cross-tenant access. No other mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in Decidim verification admin functionality allows an admin from one organization to access, approve, or reject identity document verification requests belonging to participants of other organizations. This occurs because the system does not verify that the pending authorization record belongs to the current organization before allowing access and actions. The issue affects Decidim versions prior to 0.30.9. A patch is available as referenced in the Decidim GitHub pull request. As a workaround, disabling the "Identity documents" verification feature can prevent exploitation.

References

Community reviews

Loading reviews…