CVE-2026-61824: Defuddle vulnerable to XSS via unescaped attribute interpolation in site extractors
Affects defuddleSource GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 0.19.1 soon.
Data as of 30 Oct 2026, 07:30 UTC
- Patch
- Available – fixed in 0.19.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade defuddle to 0.19.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewdefuddlepkg:brew/defuddleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
## Summary An Improper Neutralization of Input During Web Page Generation issue in the site extractor component allows an attacker-controlled attribute value to be injected into output HTML without escaping. An attacker who crafts a malicious HTML page or controls content on a matching domain can execute arbitrary scripts when a victim processes the page, resulting in Cross-Site Scripting (XSS). This affects defuddle through 0.19.0 and has been patched in version 0.19.1. ## Impact This vulnerability allows for Cross-Site Scripting (XSS) execution without needing to compromise external websites. Affected consumers include: - Obsidian Web Clipper, - web services serving the parsed output directly as HTML, and - any downstream application rendering the unsanitized HTML results ## Patch This issue has been patched in defuddle version 0.19.1. Users are encouraged to update to the latest release.
References
- github.com/kepano/defuddle/security/advisories/GHSA-jg4p-g6xj-4qmf (opens in a new tab)
- github.com/kepano/defuddle/pull/326 (opens in a new tab)
- github.com/kepano/defuddle/commit/baf2eaef61d334ef595b28c89e5c5e89e52daf7f (opens in a new tab)
- github.com/kepano/defuddle (opens in a new tab)
- github.com/kepano/defuddle/releases/tag/0.19.1 (opens in a new tab)