Skip to main content
VulnerabilityPublished Updated

CVE-2026-43512: DEPRECATED · Authentication Bypass Issues vulnerability in digest authentication in Apache Tomcat

Affects tomcat6Source GCVE Database

0
Authoritative record:CVE-2026-43512· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 6.0.39-1ubuntu0.1+esm3 : patch tomcat6 as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.39-1ubuntu0.1+esm3, 7.0.52-1ubuntu0.16+esm2, 7.0.68-1ubuntu0.4+esm4 +9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • <10.1.40-1ubuntu1.26.04.1
Fixed in
  • 10.1.40-1ubuntu1.26.04.1
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • <9.0.115-1ubuntu0.1
Fixed in
  • 9.0.115-1ubuntu0.1
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=questingOther threatsAffected
  • <10.1.40-1ubuntu1.25.10.1
Fixed in
  • 10.1.40-1ubuntu1.25.10.1
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu 25.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=questingOther threatsAffected
  • <9.0.95-1ubuntu1.1
Fixed in
  • 9.0.95-1ubuntu1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

DEPRECATED: Authentication Bypass Issues vulnerability in digest authentication in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from before 7.0.0. Older unsupported versions any also be affect Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

References

Community reviews

Loading reviews…