Skip to main content
VulnerabilityPublished Updated

CVE-2026-95101: Description NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module

Affects nginxSource GCVE Database

0
Authoritative record:CVE-2026-95101· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.30.4-7ubuntu1.1 : update nginx when convenient.

Data as of 26 Oct 2026, 23:30 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.30.4-7ubuntu1.1, 1.28.3-2ubuntu1.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu nginx to 1.30.4-7ubuntu1.1 (package) or 1.28.3-2ubuntu1.12 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10nginxpkg:deb/ubuntu/nginx?arch=source&distro=stonkingOther threatsAffected
  • <1.30.4-7ubuntu1.1
Fixed in
  • 1.30.4-7ubuntu1.1
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.12
Fixed in
  • 1.28.3-2ubuntu1.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to Ubuntu package versions 1.30.4-7ubuntu1.1 or 1.28.3-2ubuntu1.12 or later. Standard system updates will apply the necessary fixes. No additional mitigations are indicated by the vendor advisory.

Description

NGINX Plus and NGINX Open Source contain a vulnerability in the ngx_http_v3_module module affecting HTTP/3 when the proxy_request_buffering directive is enabled. This flaw allows an unauthenticated remote attacker to inject data into proxied requests. The issue is limited to the data plane and does not expose the control plane. The vulnerability affects certain Ubuntu package versions and has been assigned CVE-2026-95101. Fixes are available in updated package versions.

References

Community reviews

Loading reviews…