versions of the Keras framework running · Deserialization of Untrusted Data Can Occur
Affects kerasSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical.
Data as of 29 Oct 2026, 22:54 UTC
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 20.04 LTSkeraspkg:deb/ubuntu/keras?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSkeraspkg:deb/ubuntu/keras?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Keras version 3.11.3 or later, where this vulnerability is fixed. Since the vulnerability affects specific versions prior to 3.11.3, applying the official patch by updating to 3.11.3 is the recommended remediation. No alternative mitigations are indicated.
Description
A critical deserialization vulnerability exists in Keras versions 3.11.0 up to but not including 3.11.3. This flaw allows a maliciously crafted Keras file containing a TorchModuleWrapper class to execute arbitrary code on the user's system when loaded, even if safe mode is enabled. The vulnerability can be exploited via both local and remote files.