Skip to main content
VulnerabilityPublished Updated

CVE-2024-37059: versions of the MLflow platform running · Deserialization of Untrusted Data Can Occur

Affects mlflowSource GCVE Database

0

Not known to be exploited : upgrade to 2.14.2 soon.

Data as of 26 Oct 2026, 12:54 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mlflow to 2.14.2.

Affected software

ProductAffectedFixed in
Bitnamimlflowpkg:bitnami/mlflowOther threatsAffected
  • >=0.5.0 <2.14.2
Fixed in
  • 2.14.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade MLflow to version 2.14.2 or later to remediate this issue. Since this is not a cloud service, remediation requires manual upgrade by the user or administrator.

Description

A deserialization vulnerability exists in the MLflow platform versions 0.5.0 up to but not including 2.14.2. This flaw allows a maliciously crafted PyTorch model uploaded to the platform to execute arbitrary code on the system of an end user who interacts with it.

References

Community reviews

Loading reviews…