CVE-2024-37060: versions of the MLflow platform running · Deserialization of Untrusted Data Can Occur
Affects mlflowSource GCVE Database
Not known to be exploited : upgrade to 2.14.2 soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.2
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade mlflow to 2.14.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimlflowpkg:bitnami/mlflowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade MLflow to version 2.14.2 or later to remediate this issue. Until patched, avoid running untrusted Recipes to prevent exploitation.
Description
A deserialization vulnerability exists in the MLflow platform versions 1.27.0 and newer up to but not including 2.14.2. This flaw allows a maliciously crafted Recipe to execute arbitrary code on an end user's system when run. The vulnerability is classified as high severity. A patch is available to address this issue.