Skip to main content
VulnerabilityPublished Updated

CVE-2026-78162: Apache Camel · Deserialization of Untrusted Data Vulnerability

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-78162· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 4.22.1 or 4.18.5 as a priority.

Data as of 3 Nov 2026, 16:43 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.22.1, 4.18.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Apache to 4.22.1 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-hazelcastAffected
  • >=4.19.0 <4.22.1
Fixed in
  • 4.22.1
Apache Camelorg.apache.camel:camel-hazelcastAffected
  • >=4.0.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-hazelcastpkg:maven/Apache Software Foundation/org.apache.camel:camel-hazelcastOther threatsAffected
  • >=4.0.0 <4.18.5
  • >=4.19.0 <4.22.1
Fixed in
  • 4.18.5
  • 4.22.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Camel to version 4.23.0 or later. If on the 4.22.x stream, upgrade to 4.22.1; if on 4.18.x, upgrade to 4.18.5. Versions 4.14.x and earlier are end-of-life and will not receive fixes, so upgrading to a supported release is necessary. For deployments that cannot upgrade immediately, mitigations include supplying an explicit Hazelcast configuration with a JavaSerializationFilterConfig, injecting a pre-built HazelcastInstance (which Camel does not overwrite), setting the JVM-wide serialization filter via -Djdk.serialFilter to restrict deserialization, and enabling Hazelcast cluster authentication and TLS to limit access to the cluster. These mitigations reduce the risk until an upgrade can be performed.

Description

A deserialization of untrusted data vulnerability exists in Apache Camel's camel-hazelcast component in versions from 4.0.0 before 4.18.5 and from 4.19.0 before 4.22.1. Certain configuration paths fail to apply Java deserialization filters, allowing an attacker able to publish data into the connected Hazelcast cluster to cause arbitrary Java object deserialization, potentially leading to remote code execution. Hazelcast clusters lack authentication and TLS by default, increasing exposure. Upgrades to Apache Camel 4.23.0, 4.22.1, or 4.18.5 fix this issue. Workarounds include supplying explicit Hazelcast configurations with deserialization filters, injecting pre-built Hazelcast instances, setting JVM-wide serialization filters, and enabling Hazelcast cluster authentication and TLS.

References

Community reviews

Loading reviews…