CVE-2026-64606: fory · Deserialization of untrusted data vulnerability that may allow class-registration checks to be
Affects forySource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.4.0 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.fory/fory to 1.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.fory/forypkg:maven/org.apache.fory/foryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Fory to version 1.4.0 or later, where this vulnerability is fixed. No other mitigation is specified or required according to the available data.
Description
CVE-2026-64606 is a deserialization of untrusted data vulnerability in Apache Fory before version 1.4.0. It allows bypassing class-registration checks during Java lambda deserialization, affecting only the lambda capture class. The issue is fixed in Apache Fory version 1.4.0.