CVE-2026-41327: Dgraph · Pre-Auth Full Database Exfiltration via DQL Injection in Upsert Condition Field
Affects github.com/dgraph-io/dgraph/v25Source GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 25.3.3 as a priority.
Data as of 27 Oct 2026, 01:25 UTC
- Patch
- Available – fixed in 25.3.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade github.com/dgraph-io/dgraph/v25 to 25.3.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/dgraph-io/dgraph/v25 | Affected
| Fixed in
|
| Gogithub.com/dgraph-io/dgraph/v24 | Affected
| Fixed in– |
| Gogithub.com/dgraph-io/dgraph | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Dgraph version 25.3.3. Users should upgrade to this version or later to remediate the vulnerability. Since the issue arises from lack of ACL configuration, enabling and properly configuring ACL can also mitigate the risk. No other specific mitigations are indicated by the vendor advisory.
Description
A critical injection vulnerability in Dgraph allows unauthenticated attackers to exfiltrate the entire database when ACL is disabled (default configuration). The flaw arises from improper sanitization of the 'cond' field in upsert mutations, enabling injection of additional DQL query blocks that execute server-side and return data in HTTP responses. This bypasses authentication and authorization checks, leading to full read access and potential manipulation of mutation logic. The vulnerability affects versions prior to 25.3.3, 24.1.8, and 1.2.8.