Skip to main content
VulnerabilityPublished Updated

CVE-2024-39329: Django vulnerable to user enumeration attack

Affects DjangoSource GCVE Database

0
Compare
Authoritative record:CVE-2024-39329· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.0.7 when convenient.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.0.7, 4.2.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Django to 5.0.7; Django to 4.2.14.

Affected software

ProductAffectedFixed in
PyPIDjangoAffected
  • >=5.0 <5.0.7
Fixed in
  • 5.0.7
PyPIDjangoAffected
  • >=4.2 <4.2.14
Fixed in
  • 4.2.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to Django versions 5.0.7 or 4.2.14 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Django versions 5.0 prior to 5.0.7 and 4.2 prior to 4.2.14 contain a vulnerability in the authentication backend that allows remote attackers to enumerate valid users via a timing attack on login requests involving users with unusable passwords. This issue has been fixed in versions 5.0.7 and 4.2.14.

References

Community reviews

Loading reviews…