Skip to main content
VulnerabilityPublished

CVE-2026-111497: Dotnet · Out-of-Bounds Write in Google Brotli Decoder

Affects Google dotnetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111497· Critical 9.2

Exploited in the wild · KEV due 10 Nov 2026 · fixed in 10.0.14 : patch Google dotnet now.

Data as of 29 Oct 2026, 13:17 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Google)CVSS 4.09.2
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 10.0.14, 9.0.22, 8.0.33
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Google LLC

    , 6 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 4 days after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Google dotnet to 10.0.14, 9.0.22 or 8.0.33.

Affected software

ProductAffectedFixed in
Bitnamidotnetpkg:bitnami/dotnetOther threatsAffected
  • >=8.0.0 <8.0.33
  • >=9.0.0 <9.0.22
  • >=10.0.0 <10.0.14
Fixed in
  • 8.0.33
  • 9.0.22
  • 10.0.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A buffer overflow vulnerability exists in the Brotli decoder component of Google Brotli versions 1.0.3 through 1.2.0. This flaw allows a remote unauthenticated attacker to corrupt adjacent memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution. Fixed versions are available and users should update to versions 1.0.10, 1.1.1, or 1.2.1 to remediate this issue.

References

Community reviews

Loading reviews…