Skip to main content
VulnerabilityPublished Updated

CVE-2025-59028: Dovecot · When sending invalid base64 SASL data, login process is disconnected from the auth server

Affects dovecotSource GCVE Database

0
Authoritative record:CVE-2025-59028· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1:2.4.1+dfsg1-5ubuntu4.1 when convenient.

Data as of 27 Oct 2026, 01:13 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:2.4.1+dfsg1-5ubuntu4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu dovecot package to 1:2.4.1+dfsg1-5ubuntu4.1.

Affected software

ProductAffectedFixed in
Ubuntu 25.10dovecotpkg:deb/ubuntu/dovecot?arch=source&distro=questingOther threatsAffected
  • <1:2.4.1+dfsg1-5ubuntu4.1
Fixed in
  • 1:2.4.1+dfsg1-5ubuntu4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update provided by Ubuntu by upgrading to dovecot-core version 1:2.4.1+dfsg1-5ubuntu4.1 or later as detailed in Ubuntu Security Notice USN-8136-1. Alternatively, concurrency in login processes can be disabled, but this causes a significant performance penalty on large deployments. Since a patch is available, installing the fixed version is the recommended mitigation.

Description

Dovecot versions prior to 1:2.4.1+dfsg1-5ubuntu4.1 and several specific 2.3 and 2.4.1 Ubuntu package versions contain a vulnerability where sending invalid base64 SASL data causes the login process to disconnect from the authentication server. This results in denial of service (DoS) by breaking all active authentication sessions. The issue affects Ubuntu 25.10 and can be mitigated by installing the fixed package or disabling concurrency in login processes, though the latter has a significant performance impact. No public exploits are currently known.

References

Community reviews

Loading reviews…