Skip to main content
VulnerabilityPublished

CVE-2026-2219: dpkg vulnerability

Affects dpkgSource GCVE Database

0
Authoritative record:CVE-2026-2219· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 1.22.6ubuntu6.6 : patch dpkg soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.22.6ubuntu6.6, 1.22.21ubuntu3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu dpkg to 1.22.6ubuntu6.6 (package) or 1.22.21ubuntu3.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10dpkgpkg:deb/ubuntu/dpkg?arch=source&distro=questingOther threatsAffected
  • <1.22.21ubuntu3.2
Fixed in
  • 1.22.21ubuntu3.2
Ubuntu 24.04 LTSdpkgpkg:deb/ubuntu/dpkg?arch=source&distro=nobleOther threatsAffected
  • <1.22.6ubuntu6.6
Fixed in
  • 1.22.6ubuntu6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Yashashree Gund discovered that the dpkg dpkg-deb tool incorrectly handled certain zstd-compressed .deb archives. If a user or automated system were tricked into manipulating a specially crafted .deb archive, a remote attacker could possibly use this issue to cause dpkg-deb to stop responding, resulting in a denial of service.

References

Community reviews

Loading reviews…