CVE-2026-119196: Dstack · pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding
Affects dstackSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 0.22.6 soon.
Data as of 31 Oct 2026, 17:08 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.22.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade dstack to 0.22.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewdstackpkg:brew/dstackOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in pyasn1 version 0.22.6. Users should upgrade to this version or later to remediate the issue. Applications should also consider input validation and limits on ASN.1 fragment counts if feasible. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2026-119196 is a high-severity vulnerability in pyasn1 through version 0.6.4 that causes quadratic CPU consumption when decoding constructed BIT STRING values with many fragments. This can lead to CPU exhaustion and denial of service during ASN.1 decoding. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. The vulnerability arises from inefficient bit shifting operations in the decoder implementation. A fix is available in pyasn1 version 0.22.6.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-2qm8-x737-gmw5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119196 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/73ba7b043cc7e92cb37f16f2c955bff93b0e6f6c (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)