Dstack: pyasn1 has quadratic-time denial of service in constructed string and indefinite-length ANY decoding
Affects dstackSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 0.22.6 soon.
Data as of 31 Oct 2026, 17:08 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.22.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade dstack to 0.22.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewdstackpkg:brew/dstackOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pyasn1 version 0.22.6. Users should upgrade to version 0.22.6 or later to remediate this vulnerability. Until upgraded, applications should implement input validation and resource limits to mitigate potential CPU exhaustion from crafted ASN.1 inputs.
Description
pyasn1 versions up to 0.6.4 have a quadratic-time denial of service vulnerability in decoding constructed OCTET STRINGs, constructed character strings, and indefinite-length ANY types in BER and CER encoding. This causes excessive CPU usage when processing many small fragments, potentially leading to CPU exhaustion. The issue affects applications that decode attacker-controlled ASN.1 input without proper limits. No confidentiality or integrity impact is reported. The vulnerability is fixed in pyasn1 version 0.22.6.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-9m75-vc3g-4x39 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119195 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/4ce00797c594b59c1fd6b86d9ebc3ba87b7ec9f9 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)