Skip to main content
VulnerabilityPublished Updated

gix_submodule::File::update() Enables Arbitrary Command Execution · Duplicate Advisory: gitoxide: CommandForbiddenInModulesConfiguration Bypass

Affects gixSource GCVE Database

0

CVSS 7.8 High : upgrade to 0.83.0 soon.

Data as of 18 Jul 2026, 12:55 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.83.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade gix to 0.83.0.

Affected software

ProductAffectedFixed in
crates.iogixAffected
  • >=0.31.0 <0.83.0
Fixed in
  • 0.83.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid using affected versions or restrict usage of untrusted .gitmodules files.

Description

gix-submodule versions from 0.31.0 up to but not including 0.83.0 have a vulnerability in the validation of the update field in .gitmodules. This flaw allows attackers to bypass command execution restrictions and inject arbitrary shell commands that execute during submodule updates. The advisory is a duplicate and has been withdrawn in favor of another GHSA identifier.

References

Community reviews

Loading reviews…