Skip to main content
VulnerabilityPublished Updated

getgrav/grav · Duplicate Advisory: Grav: UserInterface offsetget/offsetexists allow-listed

Affects getgrav/gravSource GCVE Database

0

CVSS 6.5 Medium · fixed in 2.0.16 : update getgrav/grav when convenient.

Data as of 18 Sep 2026, 01:27 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.16
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

What to do

Affected software

ProductAffectedFixed in
Packagistgetgrav/gravAffected–Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Grav CMS version 2.0.16 and later. Users should upgrade to version 2.0.16 or newer to remediate this vulnerability. No additional mitigation steps are indicated in the advisory.

Description

Grav CMS versions before 2.0.16 contain a vulnerability in sandboxed Twig templates where allow-listed offsetGet() and offsetexists() methods on User objects do not filter sensitive fields. This allows attackers with page-edit permissions to access hashed passwords and two-factor authentication secrets. The vulnerability enables offline password cracking and potential authentication bypass.

References

Community reviews

Loading reviews…