Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: PickleScan has multiple stdlib modules with direct RCE not in blocklist

Affects picklescanSource GCVE Database

0

CVSS 9.8 Critical : upgrade to 1.0.4 as a priority.

Data as of 24 Sep 2026, 07:00 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade picklescan to 1.0.4.

Affected software

ProductAffectedFixed in
PyPIpicklescanAffected
  • <1.0.4
Fixed in
  • 1.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for PickleScan to address this vulnerability. Users should upgrade to version 1.0.4 or later to ensure these modules are properly blocked and remote code execution is prevented.

Description

PickleScan versions before 1.0.4 do not block certain Python standard library modules that allow direct arbitrary command execution. This flaw enables attackers to craft malicious pickle files that import these unblocked modules, bypassing PickleScan's safety validation and leading to remote code execution. The advisory has been withdrawn as a duplicate of GHSA-g38g-8gr9-h9xp but remains for reference.

References

Community reviews

Loading reviews…