Skip to main content
CVE-2026-119195VulnerabilityPublished

Duplicity: pyasn1 has quadratic-time denial of service in constructed string and indefinite-length ANY decoding

Affects duplicitySource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-119195· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 0.8.03 soon.

Data as of 31 Oct 2026, 17:08 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 0.8.03
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade duplicity to 0.8.03.

Affected software

ProductAffectedFixed in
Homebrewduplicitypkg:brew/duplicityOther threatsAffected
  • >=0.7.06_1 <0.8.03
  • >=0.8.05_1
Fixed in
  • 0.8.03

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in pyasn1 version 0.8.03. Users of affected versions should upgrade to 0.8.03 or later to remediate this vulnerability. Until upgraded, applications should implement input validation and resource limits to prevent processing of large or excessive ASN.1 constructed strings or indefinite-length ANY types. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.

Description

Duplicity uses the pyasn1 library which in versions 0.6.4 and earlier suffers from a quadratic-time denial of service vulnerability during decoding of constructed OCTET STRINGs and indefinite-length ANY types. This flaw causes CPU exhaustion when decoding specially crafted ASN.1 inputs with many fragments, as the decoder repeatedly copies accumulated data in an inefficient manner. The vulnerability affects BER and CER decoding paths and certain non-conforming DER inputs. No confidentiality or integrity impact is reported, but repeated exploitation can cause denial of service by exhausting CPU resources.

References

Community reviews

Loading reviews…