CVE-2026-119194: Dvc · pyasn1 has quadratic CPU use in schemaless BER/CER/DER container decoding
Affects dvcSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 3.67.1_19 soon.
Data as of 31 Oct 2026, 16:21 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 3.67.1_19
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade dvc to 3.67.1_19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewdvcpkg:brew/dvcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in dvc version 3.67.1_19 that addresses this vulnerability by limiting the growth of the classification set during decoding. Users should upgrade to version 3.67.1_19 or later to mitigate this issue. No additional mitigation actions are required beyond applying the official fix.
Description
CVE-2026-119194 is a vulnerability in the pyasn1 library used by the dvc product that causes quadratic CPU usage when decoding attacker-controlled BER, CER, or DER data without an ASN.1 schema. An attacker can craft inputs with many distinct long tag IDs that cause excessive CPU consumption, potentially leading to denial of service by exhausting CPU resources. The issue affects dvc versions from 1.4.0 up to but not including 3.67.1_19. A fix is available in version 3.67.1_19. No confidentiality or integrity impacts were observed.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-fm9c-5rcf-2q5p (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119194 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/a36e3a3d067148d26197a6b7221fd0e2cde9cc86 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)