CVE-2025-27111: Rack lead to Possible Log Injection · Escape Sequence Injection Vulnerability
Affects rackSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.2.12 when convenient.
Data as of 31 Oct 2026, 01:26 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 2.2.12, 3.0.13, 3.1.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade rack to 2.2.12; rack to 3.0.13; rack to 3.1.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsrack | Affected
| Fixed in
|
| RubyGemsrack | Affected
| Fixed in
|
| RubyGemsrack | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Rack versions 2.2.12, 3.0.13, and 3.1.11. Users should update to these versions to remediate the vulnerability. Alternatively, removing the use of Rack::Sendfile middleware will mitigate the issue. No other specific mitigations are indicated.
Description
CVE-2025-27111 is a vulnerability in the Rack middleware component Rack::Sendfile that allows an attacker to inject escape sequences, such as newline characters, into the X-Sendfile-Type header. This leads to log injection, which can distort log files and hinder security auditing and incident investigation. The issue affects multiple Rack versions prior to 2.2.12, and versions 3.0 up to but not including 3.0.13, as well as 3.1 up to but not including 3.1.11. The vulnerability has a medium severity rating with a CVSS score of 6.9. A fix is available in Rack versions 2.2.12, 3.0.13, and 3.1.11. Mitigation involves updating to these fixed versions or removing the use of Rack::Sendfile.
References
- github.com/rack/rack/security/advisories/GHSA-8cgq-6mh2-7j6v (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-27111 (opens in a new tab)
- github.com/rack/rack/commit/803aa221e8302719715e224f4476e438f2531a53 (opens in a new tab)
- github.com/rack/rack/commit/aeac570bb8080ca7b53b7f2e2f67498be7ebd30b (opens in a new tab)
- github.com/rack/rack/commit/b13bc6bfc7506aca3478dc5ac1c2ec6fc53f82a3 (opens in a new tab)
- github.com/rack/rack (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2025-27111.yml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00016.html (opens in a new tab)