CVE-2026-23833: ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component
Affects esphomeSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 2025.12.7 when convenient.
Data as of 30 Oct 2026, 07:30 UTC
- Patch
- Available – fixed in 2025.12.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade esphome to 2025.12.7.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewesphomepkg:brew/esphomeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
ESPHome is a system to control microcontrollers remotely through Home Automation systems. In versions 2025.9.0 through 2025.12.6, an integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. The bounds check `ptr + field_length > end` in `components/api/proto.cpp` can overflow when a malicious client sends a large `field_length` value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Users should upgrade to ESPHome 2025.12.7 or later to receive a patch, enable API encryption with a unique key per device, and follow the Security Best Practices.
References
- esphome.io/guides/security_best_practices (opens in a new tab)
- github.com/CVEProject/cvelistV5/tree/main/cves/2026/23xxx/CVE-2026-23833.json (opens in a new tab)
- github.com/esphome/esphome/security/advisories/GHSA-4h3h-63v6-88qx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-23833 (opens in a new tab)
- github.com/esphome/esphome/commit/69d7b6e9210390051318bd8e6410727689de08d6 (opens in a new tab)
- github.com/esphome/esphome/pull/13306 (opens in a new tab)