CVE-2024-7102: GitLab · Execution with Unnecessary Privileges
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.5.0 as a priority.
Data as of 26 Oct 2026, 07:57 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.5.0
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 17.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to version 17.5.0 or later to remediate this issue. Since this is not a cloud service, remediation requires manual update by administrators. No known exploits are reported in the wild at this time.
Description
A vulnerability in GitLab CE/EE versions from 16.4 up to but not including 17.5.0 allows an attacker to trigger a pipeline as another user under certain conditions. This issue involves execution with unnecessary privileges, potentially enabling privilege escalation within the affected GitLab instances.