Skip to main content
CVE-2025-4976VulnerabilityPublished Updated

CVE-2025-4976: Exposure of Sensitive Information Due to Incompatible Policies in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.2.1 : update gitlab when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2.1, 18.1.3, 18.0.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade gitlab to 18.2.1, 18.1.3 or 18.0.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.0.0 <18.0.5
  • >=18.1.0 <18.1.3
  • >=18.2.0 <18.2.1
Fixed in
  • 18.0.5
  • 18.1.3
  • 18.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab EE instances to versions 18.0.5 or later, 18.1.3 or later, or 18.2.1 or later to remediate the issue. No additional mitigation steps are indicated.

Description

A vulnerability in GitLab EE versions from 17.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 could allow an attacker to access internal notes in GitLab Duo responses due to incompatible policies. This issue exposes sensitive information under certain conditions. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…