CVE-2026-108823: Exposure of Sensitive Information to an Unauthorized Actor during job manipulation in Apache Kylin
Source GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 5.0.5 : patch Apache Kylin soon.
Data as of 4 Nov 2026, 02:28 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 5.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Kylin | Affected
| Fixed in– |
Mavenorg.apache.kylin/kylinpkg:maven/org.apache.kylin/kylinOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Kylin to version 5.0.5 or later to remediate this vulnerability. Since the issue is fixed in this release, no additional mitigation steps are required if the upgrade is applied.
Description
A vulnerability in Apache Kylin versions 4.0.0 through 5.0.4 allows exposure of sensitive information to unauthorized actors during job manipulation. The impact is considered minor unless job services are exposed to a public network, which is uncommon. The issue is fixed in version 5.0.5.