Skip to main content
VulnerabilityPublished Updated

CVE-2024-5067: Exposure of Sensitive Information to an Unauthorized Actor in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.2.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 12:54 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.2.1, 17.1.3, 17.0.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.2.1, 17.1.3 or 17.0.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.11.0 <17.0.5
  • >=17.1.0 <17.1.3
  • >=17.2.0 <17.2.1
Fixed in
  • 17.0.5
  • 17.1.3
  • 17.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab EE to versions 17.0.5, 17.1.3, or 17.2.1 or later. Since a patch is available, remediation should be performed promptly to prevent exposure of sensitive analytics data.

Description

A vulnerability in GitLab EE allows certain project-level analytics settings to be exposed in the DOM to group members with Developer or higher roles. This affects versions from 16.11 up to but not including 17.0.5, 17.1 up to but not including 17.1.3, and 17.2 up to but not including 17.2.1. The exposure could lead to unauthorized access to sensitive project analytics data within the group.

References

Community reviews

Loading reviews…