Skip to main content
VulnerabilityPublished

CVE-2026-58024: mediawiki · Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation

Affects mediawikiSource GCVE Database

0
Authoritative record:CVE-2026-58024· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 1.46.0 : update mediawiki when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.46.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10mediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=stonkingOther threatsAffected
  • =1:1.43.8+dfsg-2
  • =1:1.43.9+dfsg-1
  • =1:1.43.9+dfsg-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=resoluteOther threatsAffected
  • 1:1.43.3+dfsg-1 – 1:1.43.8+dfsg-2
5 affected builds
Fixed in–
Ubuntu 25.10mediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=questingOther threatsAffected
  • =1:1.43.1+dfsg-1
  • =1:1.43.1+dfsg-2
  • =1:1.43.3+dfsg-1
Fixed in–
Ubuntu Pro 24.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 1:1.39.4-2 – 1:1.39.7-1ubuntu0.1~esm1
5 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1:1.35.3-1 – 1:1.35.6-1ubuntu0.1~esm1
8 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSmediawikipkg:deb/ubuntu/mediawiki?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1:1.31.2-1ubuntu1 – 1:1.31.7-1ubuntu0.1~esm1
9 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MediaWiki version 1.46.0 and later. Users should upgrade to version 1.46.0 or newer to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the official patch by upgrading the software. No vendor advisory content was provided to indicate alternative mitigations or if the issue is already mitigated in certain environments.

Description

CVE-2026-58024 is a medium severity vulnerability in Wikimedia Foundation MediaWiki that allows unauthorized actors to access sensitive information. It is related to the file includes/Api/ApiUserrights.Php and affects multiple versions prior to 1.46.0, including certain 1.43.x, 1.44.x, and 1.45.x releases. The vulnerability has a CVSS score of 5.7.

References

Community reviews

Loading reviews…