Skip to main content
VulnerabilityPublished

FastMCP: Post-transform component authorization is skipped on direct calls

Affects fastmcpSource GCVE Database

0

CVSS 6.8 Medium : upgrade to 4.1.2 when convenient.

Data as of 30 Oct 2026, 10:15 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.1.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

What to do

Upgrade fastmcp to 4.1.2.

Affected software

ProductAffectedFixed in
Homebrewfastmcppkg:brew/fastmcpOther threatsAffected
  • >=3.0.0 <4.1.2
Fixed in
  • 4.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the available fixes by upgrading to FastMCP versions 3.4.10 or 4.1.2, which enforce authorization after all transforms. Until upgrading, avoid configurations with overlapping proxy templates for protected resources and enforce authorization at the handler or server boundary rather than relying solely on component policies affected by transforms.

Description

FastMCP versions 3.0.0 through 4.1.1 have an authorization bypass vulnerability where direct calls to transformed components skip the final authorization check. This allows low-privilege users to invoke protected tools, resources, templates, or prompts that should be denied. The issue arises because transforms are applied before authorization, but the authorization check is not re-applied to the transformed component. Fixes are available in FastMCP 3.4.10 and 4.1.2.

References

Community reviews

Loading reviews…