Skip to main content
CVE-2026-73699VulnerabilityPublished

CVE-2026-73699: FileRun before 2026.3.0 contains a PHP object injection vulnerability that allows authenticated attackers to execute arbitrary code by exploiting

Affects filerunSource GCVE Database

0

Not known to be exploited · CVSS 7.2 High : upgrade to 2026.3.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.3.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade filerun/filerun to 2026.3.0.

Affected software

ProductAffectedFixed in
Packagistfilerun/filerunpkg:composer/filerun/filerunOther threatsAffected
  • <2026.3.0
Fixed in
  • 2026.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in FileRun version 2026.3.0. Users should upgrade to this version or later to remediate the vulnerability. No alternative mitigations or temporary fixes are indicated. Since this is not a cloud service, patching the software is required to address the issue.

Description

FileRun versions prior to 2026.3.0 have a PHP object injection vulnerability in the Perms::getPerms() method. This flaw allows authenticated attackers with database write access to execute arbitrary code by injecting a serialized gadget chain into the permissions table. The vulnerability arises from incorrect options passed to unserialize(), enabling attackers to write arbitrary files such as PHP webshells to web-accessible locations.

References

Community reviews

Loading reviews…