Skip to main content
VulnerabilityPublished Updated

CVE-2024-25128: Flask-AppBuilder vulnerable to incorrect authentication when using auth type OpenID

Affects Flask-AppBuilderSource GCVE Database

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.3.11 as a priority.

Data as of 27 Oct 2026, 17:30 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.3.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Flask-AppBuilder to 4.3.11.

Affected software

ProductAffectedFixed in
PyPIFlask-AppBuilderAffected
  • <4.3.11
Fixed in
  • 4.3.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flask-AppBuilder to version 4.3.11 or later, where this vulnerability is fixed. If upgrading is not immediately possible, apply the provided workaround by customizing the authentication view to validate OpenID URLs against a whitelist of known providers, preventing acceptance of arbitrary OpenID services. No other actions are specifically required beyond these targeted mitigations.

Description

Flask-AppBuilder versions prior to 4.3.11 using the deprecated OpenID 2.0 authentication protocol (AUTH_TYPE AUTH_OID) are vulnerable to incorrect authentication. An attacker can forge HTTP requests to trick the backend into accepting any OpenID service, potentially gaining unauthorized privileged access if a malicious OpenID provider is accessible. This vulnerability is critical and has a CVSS score of 9.1. The issue is fixed in version 4.3.11. A workaround is available for those unable to upgrade immediately.

References

Community reviews

Loading reviews…