Skip to main content
CVE-2026-34079VulnerabilityPublished Updated

CVE-2026-34079: Flatpak · Prior to 1.16.4, the caching for ld.so removes outdated cache files without properly checking that the app controlled path to the outdated cache is

Affects flatpakSource GCVE Database

0

Not known to be exploited · CVSS 7.5 Medium · fixed in 1.16.4 : update flatpak when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.16.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Ubuntu:18.04:LTSflatpakpkg:deb/ubuntu/flatpak?arch=source&distro=bionicOther threatsAffected
  • =0.8.7-5
  • =0.10.0-1
  • =0.10.0-2
  • =0.10.1-1
  • =0.10.2-1
  • =0.10.2.1-1
  • =0.10.2.1-2
  • =0.10.3-1
  • =0.11.1-0ubuntu1
  • =0.11.3-2
  • =0.11.3-3
  • =0.11.7-0ubuntu0.1
  • =1.0.1-0ubuntu0.1
  • =1.0.6-0ubuntu0.1
  • =1.0.7-0ubuntu0.18.04.1
  • =1.0.8-0ubuntu0.18.04.1
  • =1.0.9-0ubuntu0.1
  • =1.0.9-0ubuntu0.2
  • =1.0.9-0ubuntu0.3
  • =1.0.9-0ubuntu0.4
Fixed in–
Ubuntu:Pro:20.04:LTSflatpakpkg:deb/ubuntu/flatpak?arch=source&distro=esm-apps/focalOther threatsAffected
  • =1.4.3-1
  • =1.6.0-1
  • =1.6.1-1
  • =1.6.2-1
  • =1.6.3-1
  • =1.6.5-0ubuntu0.1
  • =1.6.5-0ubuntu0.2
  • =1.6.5-0ubuntu0.3
  • =1.6.5-0ubuntu0.4
  • =1.6.5-0ubuntu0.5
  • =1.6.5-0ubuntu0.5+esm1
Fixed in–
Ubuntu:Pro:22.04:LTSflatpakpkg:deb/ubuntu/flatpak?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =1.10.2-3
  • =1.12.2-1
  • =1.12.2-2
  • =1.12.3-1
  • =1.12.4-1
  • =1.12.5-1
  • =1.12.6-1
  • =1.12.7-1
  • =1.12.7-1ubuntu0.1
  • =1.12.7-1ubuntu0.1+esm1
Fixed in–
Ubuntu:Pro:24.04:LTSflatpakpkg:deb/ubuntu/flatpak?arch=source&distro=esm-apps/nobleOther threatsAffected
  • =1.14.4-2
  • =1.14.5-1
  • =1.14.5-1build1
  • =1.14.5-1build4
  • =1.14.5-1build5
  • =1.14.5-1build6
  • =1.14.6-1
  • =1.14.6-1ubuntu0.1
  • =1.14.6-1ubuntu0.1+esm1
Fixed in–
Ubuntu:25.10flatpakpkg:deb/ubuntu/flatpak?arch=source&distro=questingOther threatsAffected
  • =1.16.0-2
  • =1.16.1-1build1
  • =1.16.1-2
  • =1.16.1-2ubuntu1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Flatpak version 1.16.4. Users and administrators should upgrade to version 1.16.4 or later to remediate this issue. No other mitigations are indicated by the vendor advisory.

Description

Flatpak versions prior to 1.16.4 contain a vulnerability in the ld.so caching mechanism where outdated cache files are removed without properly verifying that the path to the outdated cache is within the cache directory. This flaw allows Flatpak applications to delete arbitrary files on the host system. The issue is resolved in Flatpak version 1.16.4.

References

Community reviews

Loading reviews…