Skip to main content
CVE-2025-6176VulnerabilityPublished Updated

Flexget: Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression implementation

Affects flexgetSource GCVE Database

0
Authoritative record:CVE-2025-6176· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 3.18.21_1 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.18.21_1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade flexget to 3.18.21_1.

Affected software

ProductAffectedFixed in
Homebrewflexgetpkg:brew/flexgetOther threatsAffected
  • >=3.17.7 <3.18.21_1
Fixed in
  • 3.18.21_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Scrapy versions up to 2.13.3 are vulnerable to a denial of service (DoS) attack due to a flaw in its brotli decompression implementation. The protection mechanism against decompression bombs fails to mitigate the brotli variant, allowing remote servers to crash clients with less than 80GB of available memory. This occurs because brotli can achieve extremely high compression ratios for zero-filled data, leading to excessive memory consumption during decompression. Mitigation for this vulnerability needs security enhancement added in brotli v1.2.0.

References

Community reviews

Loading reviews…