CVE-2026-44025: Fluentd is Vulnerable to Exposure of Sensitive Information via Monitor Agent API
Affects fluentdSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.19.3 soon.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.19.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade fluentd to 1.19.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsfluentd | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Fluentd version 1.19.3 that fixes this vulnerability. Users should upgrade to version 1.19.3 or later to remediate the issue. Until upgrading, it is recommended to restrict access to the Monitor Agent port (default 24220) to localhost only or block the port using firewall rules to prevent unauthorized network access.
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.
References
- github.com/fluent/fluentd/commit/990921518971699b9a97441970674d1800e29177 (opens in a new tab)
- github.com/fluent/fluentd/pull/5392 (opens in a new tab)
- github.com/fluent/fluentd/releases/tag/v1.19.3 (opens in a new tab)
- github.com/fluent/fluentd/security/advisories/GHSA-pr7j-96cj-549h (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44025 (opens in a new tab)