CVE-2026-44024: Fluentd is Vulnerable to Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder
Affects fluentdSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.19.3 as a priority.
Data as of 26 Oct 2026, 11:07 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.19.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade fluentd to 1.19.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsfluentd | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available in Fluentd version 1.19.3. Users should upgrade to this version or later to remediate the vulnerability. Additional mitigations include restricting network access to Fluentd, running Fluentd processes with non-root privileges, avoiding the use of the ${tag} placeholder in file paths when tags come from untrusted sources, and filtering incoming tags to block path traversal or other malicious characters.
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.
References
- github.com/fluent/fluentd/commit/45c87a81f3ac0b72b3f9dcfe8cfb5f9038f81437 (opens in a new tab)
- github.com/fluent/fluentd/pull/5391 (opens in a new tab)
- github.com/fluent/fluentd/releases/tag/v1.19.3 (opens in a new tab)
- github.com/fluent/fluentd/security/advisories/GHSA-44hj-4m45-frj3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44024 (opens in a new tab)