CVE-2026-44161: Fluentd is Vulnerable to Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`
Affects fluentdSource GCVE Database
Not known to be exploited · CVSS 7.2 High : upgrade to 1.19.3 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.19.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade fluentd to 1.19.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsfluentd | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available in Fluentd version 1.19.3. Users should upgrade to this version to remediate the vulnerability. Until patched, mitigations include avoiding the use of dynamic hostnames in HTTP endpoint configurations, restricting network access to sensitive internal IP addresses, and filtering allowed hosts in placeholder expansions to prevent untrusted input from controlling request destinations.
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.
References
- github.com/fluent/fluentd/commit/c6a01ea2e0ea01977f8d615f7c6dbfae4cba88c9 (opens in a new tab)
- github.com/fluent/fluentd/pull/5394 (opens in a new tab)
- github.com/fluent/fluentd/releases/tag/v1.19.3 (opens in a new tab)
- github.com/fluent/fluentd/security/advisories/GHSA-72f5-rr8c-r6gr (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-44161 (opens in a new tab)