Skip to main content
VulnerabilityPublished

CVE-2026-120067: For updatable cursors, which are enabled by default, psqlODBC adds hidden ctid and, for tables with

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-120067· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 18.00.0006 when convenient.

Data as of 2 Nov 2026, 23:28 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.15.9
Patch
Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade psqlODBC to 18.00.0006.

Affected software

ProductAffectedFixed in
PostgreSQLpsqlODBCAffected
  • <18.00.0006
Fixed in
  • 18.00.0006
GitHubpsqlODBCpkg:github/psqlODBCOther threatsAffected
  • <18.00.0006
Fixed in
  • 18.00.0006

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade psqlODBC to version 18.00.0006 or later where this vulnerability is fixed. Until then, restrict database users from creating views with columns named ctid if updatable cursors are used. Also, ensure that database servers are trusted and properly secured under SSL settings to prevent malicious data injection. No vendor advisory or patch links were provided, so verify patch availability from the official psqlODBC sources.

Description

A stack-based buffer overflow vulnerability exists in psqlODBC versions before 18.00.0006 when using updatable cursors, which are enabled by default. The driver adds hidden ctid and oid columns to queries and copies values into a fixed-size buffer without proper length checks. This can lead to memory corruption or application crashes if a malicious or untrusted server sends oversized values or if a database user creates a specially crafted view. Builds with _FORTIFY_SOURCE enabled abort on detection, while others may overwrite adjacent stack memory.

References

Community reviews

Loading reviews…