CVE-2026-63221: CodeIgniter · SQL injection in Query Builder deleteBatch() when used with where() conditions
Affects codeigniter4/frameworkSource GCVE Database
Not known to be exploited · CVSS 9.4 Critical : upgrade to 4.7.4 as a priority.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.7.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade codeigniter4/framework to 4.7.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistcodeigniter4/framework | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade CodeIgniter 4 to version 4.7.4 or later, where this vulnerability is fixed. If immediate upgrade is not possible, strictly validate and cast all values passed to where() before deleteBatch(), especially numeric IDs. Avoid passing user-controlled input to where() when using deleteBatch(). Instead, use normal delete() operations with Query Builder binds for user-controlled conditions. Where feasible, use batch data and onConstraint() to express matching values rather than separate user-controlled where() clauses.
Description
A critical SQL injection vulnerability exists in CodeIgniter 4's Query Builder deleteBatch() method when used with where() conditions. The vulnerability arises because bound values from the WHERE clause are directly substituted into the SQL query without proper escaping or quoting. This allows user-controlled input passed to where() before deleteBatch() to be interpreted as SQL code, enabling injection attacks. The issue affects versions from 4.3.0 up to but not including 4.7.4. A fix is available in version 4.7.4. Workarounds include strict input validation and avoiding user-controlled input in where() when using deleteBatch().
References
- github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-c9w5-rwh3-7pm9 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-63221 (opens in a new tab)
- github.com/codeigniter4/CodeIgniter4/commit/f5e463b9a3e986389ce285963e51a7f1fab6559f (opens in a new tab)
- github.com/codeigniter4/CodeIgniter4 (opens in a new tab)
- github.com/codeigniter4/CodeIgniter4/releases/tag/v4.7.4 (opens in a new tab)