Frappe CRM app before 1.89.1 contains a missing authorization vulnerability that allows authenticated low-privileged
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.89.1 soon.
Data as of 26 Oct 2026, 16:50 UTC
- Patch
- Available – fixed in 1.89.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade crm to 1.89.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| frappecrm | Affected
| Fixed in
|
GitHubcrmpkg:github/crmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Since the vulnerability affects versions before 1.89.1, upgrading to version 1.89.1 or later is implied to remediate the issue. Users should verify with the vendor or official advisories for confirmed patches or updates. Until patched, restrict access to the vulnerable API endpoint to trusted users only if possible.
Description
Frappe CRM app versions before 1.89.1 have a missing authorization vulnerability that allows authenticated low-privileged users to access CRM Lead records they should not be able to see. This occurs because the get_contact_by_phone_number API endpoint performs raw database queries without enforcing permission checks, enabling unauthorized disclosure of sensitive lead data by supplying a known phone number.