Fraunhofer HHI VVdeC before 3.2.1 contains a heap out-of-bounds read vulnerability in
Source GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.2.1 when convenient.
Data as of 7 Nov 2026, 16:04 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.1 |
- Patch
- Available – fixed in 3.2.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade vvdec to 3.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| fraunhoferhhivvdec | Affected
| Fixed in
|
GitHubvvdecpkg:github/vvdecOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Fraunhofer HHI VVdeC version 3.2.1 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Since the vulnerability is patched in 3.2.1, applying this official fix is the recommended remediation.
Description
Fraunhofer HHI VVdeC versions before 3.2.1 have a heap out-of-bounds read vulnerability in the SEIReader::xParseSEIScalableNesting function. This flaw allows attackers to read memory beyond allocated heap buffers by miscasting the SEI wrapper object instead of its payload. Exploitation requires supplying a crafted VVC bitstream with a scalable nesting SEI containing a nested buffering period SEI, which can cause the decoder to crash or leak adjacent heap memory.
References
- nvd.nist.gov/vuln/detail/CVE-2026-124309 (opens in a new tab)
- github.com/fraunhoferhhi/vvdec/issues/397 (opens in a new tab)
- github.com/fraunhoferhhi/vvdec/commit/1d657c7a822987d2ff935e9c227c5faf5318ca06 (opens in a new tab)
- github.com/fraunhoferhhi/vvdec (opens in a new tab)
- github.com/fraunhoferhhi/vvdec/blob/v3.2.0/source/Lib/CommonLib/Slice.h (opens in a new tab)
- github.com/fraunhoferhhi/vvdec/blob/v3.2.0/source/Lib/DecoderLib/SEIread.cpp (opens in a new tab)
- vulncheck.com/advisories/fraunhofer-hhi-vvdec-before-3.2.1-heap-out-of-bounds-read-via-seireader-xparseseiscalablenesting (opens in a new tab)